FailedConsole Output

Started by user sknapp
[EnvInject] - Loading node environment variables.
Building remotely on amp-jenkins-worker-01 (centos mongodb) in workspace /home/jenkins/workspace/ampcrowd
Cloning the remote Git repository
Cloning repository https://github.com/amplab/ampcrowd.git
 > git init /home/jenkins/workspace/ampcrowd # timeout=10
Fetching upstream changes from https://github.com/amplab/ampcrowd.git
 > git --version # timeout=10
 > git fetch --tags --progress https://github.com/amplab/ampcrowd.git +refs/heads/*:refs/remotes/origin/*
 > git config remote.origin.url https://github.com/amplab/ampcrowd.git # timeout=10
 > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git config remote.origin.url https://github.com/amplab/ampcrowd.git # timeout=10
Fetching upstream changes from https://github.com/amplab/ampcrowd.git
 > git fetch --tags --progress https://github.com/amplab/ampcrowd.git +refs/heads/*:refs/remotes/origin/*
 > git rev-parse refs/remotes/origin/master^{commit} # timeout=10
 > git rev-parse refs/remotes/origin/origin/master^{commit} # timeout=10
Checking out Revision 86449de9925737a38d8f836889a55567080fb1f9 (refs/remotes/origin/master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 86449de9925737a38d8f836889a55567080fb1f9
 > git rev-list 86449de9925737a38d8f836889a55567080fb1f9 # timeout=10
[ampcrowd] $ /bin/sh -xe /tmp/hudson8380941482481411086.sh
+ docker-compose build
Traceback (most recent call last):
  File "/usr/bin/docker-compose", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2655, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: six>=1.3.0,<2
Build step 'Execute shell' marked build as failure
ERROR: Failed to set Jenkins Identity header on email.
java.lang.NullPointerException
	at org.jenkinsci.main.modules.instance_identity.InstanceIdentity.get(InstanceIdentity.java:126)
	at jenkins.plugins.mailer.tasks.MimeMessageBuilder.setJenkinsInstanceIdent(MimeMessageBuilder.java:188)
	at jenkins.plugins.mailer.tasks.MimeMessageBuilder.buildMimeMessage(MimeMessageBuilder.java:166)
	at hudson.tasks.MailSender.createEmptyMail(MailSender.java:391)
	at hudson.tasks.MailSender.createFailureMail(MailSender.java:260)
	at hudson.tasks.MailSender.createMail(MailSender.java:178)
	at hudson.tasks.MailSender.run(MailSender.java:107)
	at hudson.tasks.Mailer.perform(Mailer.java:141)
	at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:74)
	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:761)
	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:721)
	at hudson.model.Build$BuildExecution.post2(Build.java:183)
	at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:670)
	at hudson.model.Run.execute(Run.java:1766)
	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
	at hudson.model.ResourceController.execute(ResourceController.java:98)
	at hudson.model.Executor.run(Executor.java:374)
Sending e-mails to: dhaas@cs.berkeley.edu
Finished: FAILURE