FailedConsole Output

[EnvInject] - Mask passwords passed as build parameters.
GitHub pull request #9498 of commit 7eacf677a29a8a318959e53f14c2f936b98a7520.
[EnvInject] - Loading node environment variables.
Building remotely on research-jenkins-worker-09 (ubuntu ubuntu-gpu research-09 ubuntu-avx2) in workspace /home/jenkins/workspace/Ray-PRB@3
[WS-CLEANUP] Deleting project workspace...
[WS-CLEANUP] Done
Cloning the remote Git repository
Cloning repository https://github.com/ray-project/ray.git
 > git init /home/jenkins/workspace/Ray-PRB@3 # timeout=10
Fetching upstream changes from https://github.com/ray-project/ray.git
 > git --version # timeout=10
 > git fetch --tags --progress https://github.com/ray-project/ray.git +refs/heads/*:refs/remotes/origin/*
 > git config remote.origin.url https://github.com/ray-project/ray.git # timeout=10
 > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git config remote.origin.url https://github.com/ray-project/ray.git # timeout=10
Fetching upstream changes from https://github.com/ray-project/ray.git
 > git fetch --tags --progress https://github.com/ray-project/ray.git +refs/pull/*:refs/remotes/origin/pr/*
 > git rev-parse 7eacf677a29a8a318959e53f14c2f936b98a7520^{commit} # timeout=10
 > git branch -a -v --no-abbrev --contains 7eacf677a29a8a318959e53f14c2f936b98a7520 # timeout=10
JENKINS-19022: warning: possible memory leak due to Git plugin usage; see: https://wiki.jenkins-ci.org/display/JENKINS/Remove+Git+Plugin+BuildsByBranch+BuildData
Checking out Revision 7eacf677a29a8a318959e53f14c2f936b98a7520 (origin/pr/9498/merge, origin/pr/9498/head)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 7eacf677a29a8a318959e53f14c2f936b98a7520
First time build. Skipping changelog.
[Ray-PRB@3] $ /bin/sh -xe /tmp/hudson271687498696625642.sh
+ export BOOST_ROOT=/opt/rise/boost
+ pwd
+ export HOME=/home/jenkins/workspace/Ray-PRB@3
+ ./ci/jenkins_tests/run_multi_node_tests.sh
+ MEMORY_SIZE=8G
+ SHM_SIZE=4G
+++ dirname /home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests/entry_point.sh
++ cd /home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests
++ pwd
+ ROOT_DIR=/home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests
+ SUPPRESS_OUTPUT=/home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests/../suppress_output
+ [[ ! -z 1 ]]
+ retry bash /home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests/run_tune_tests.sh 8G 4G
+ local n=1
+ local max=3
+ true
+ bash /home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests/run_tune_tests.sh 8G 4G
+ MEMORY_SIZE=8G
+ SHM_SIZE=4G
+ DOCKER_SHA=
+++ dirname /home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests/run_tune_tests.sh
++ cd /home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests
++ pwd
+ ROOT_DIR=/home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests
+ SUPPRESS_OUTPUT=/home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests/../suppress_output
+ '[' 8G == '' ']'
+ '[' 4G == '' ']'
+ '[' '' == '' ']'
+ echo 'Building application docker.'
Building application docker.
+ docker build -q --no-cache -t ray-project/base-deps docker/base-deps
sha256:d444b7ec0684e225dd182dbe36ae77e4c9048337b0e8aaca9521d7dbfd70b2d6
+ git rev-parse HEAD
++ git rev-parse HEAD
+ git archive -o ./docker/tune_test/ray.tar 7eacf677a29a8a318959e53f14c2f936b98a7520
+ '[' 1 == 1 ']'
++ docker build --no-cache -q -t ray-project/tune_test docker/tune_test -f docker/tune_test/build_from_source.Dockerfile
Sending build context to Docker daemon  64.55MB

Step 1/13 : FROM ray-project/base-deps
 ---> d444b7ec0684
Step 2/13 : RUN pip install -U pip
 ---> Running in 748be90f87d7
Requirement already up-to-date: pip in /opt/conda/lib/python3.6/site-packages (20.1.1)
Removing intermediate container 748be90f87d7
 ---> 587843a0d947
Step 3/13 : RUN pip install torch==1.4.0+cpu torchvision==0.5.0+cpu -f https://download.pytorch.org/whl/torch_stable.html
 ---> Running in 615db23542fa
Looking in links: https://download.pytorch.org/whl/torch_stable.html
Collecting torch==1.4.0+cpu
  Downloading https://download.pytorch.org/whl/cpu/torch-1.4.0%2Bcpu-cp36-cp36m-linux_x86_64.whl (127.2 MB)
Collecting torchvision==0.5.0+cpu
  Downloading https://download.pytorch.org/whl/cpu/torchvision-0.5.0%2Bcpu-cp36-cp36m-linux_x86_64.whl (5.4 MB)
Collecting pillow>=4.1.1
  Downloading Pillow-7.2.0-cp36-cp36m-manylinux1_x86_64.whl (2.2 MB)
Requirement already satisfied: six in /opt/conda/lib/python3.6/site-packages (from torchvision==0.5.0+cpu) (1.15.0)
Requirement already satisfied: numpy in /opt/conda/lib/python3.6/site-packages (from torchvision==0.5.0+cpu) (1.15.4)
Installing collected packages: torch, pillow, torchvision
Successfully installed pillow-7.2.0 torch-1.4.0+cpu torchvision-0.5.0+cpu
Removing intermediate container 615db23542fa
 ---> 620ada4e38ba
Step 4/13 : RUN pip install https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow_cpu-2.1.0-cp36-cp36m-manylinux2010_x86_64.whl
 ---> Running in f45a9267ade7
Collecting tensorflow-cpu==2.1.0
  Downloading https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow_cpu-2.1.0-cp36-cp36m-manylinux2010_x86_64.whl (104.6 MB)
Collecting astor>=0.6.0
  Downloading astor-0.8.1-py2.py3-none-any.whl (27 kB)
Collecting keras-applications>=1.0.8
  Downloading Keras_Applications-1.0.8-py3-none-any.whl (50 kB)
Collecting tensorboard<2.2.0,>=2.1.0
  Downloading tensorboard-2.1.1-py3-none-any.whl (3.8 MB)
Collecting wrapt>=1.11.1
  Downloading wrapt-1.12.1.tar.gz (27 kB)
Requirement already satisfied: six>=1.12.0 in /opt/conda/lib/python3.6/site-packages (from tensorflow-cpu==2.1.0) (1.15.0)
Requirement already satisfied: wheel>=0.26; python_version >= "3" in /opt/conda/lib/python3.6/site-packages (from tensorflow-cpu==2.1.0) (0.34.2)
Collecting keras-preprocessing>=1.1.0
  Downloading Keras_Preprocessing-1.1.2-py2.py3-none-any.whl (42 kB)
Collecting absl-py>=0.7.0
  Downloading absl-py-0.9.0.tar.gz (104 kB)
Collecting grpcio>=1.8.6
  Downloading grpcio-1.30.0-cp36-cp36m-manylinux2010_x86_64.whl (3.0 MB)
Collecting google-pasta>=0.1.6
  Downloading google_pasta-0.2.0-py3-none-any.whl (57 kB)
Collecting scipy==1.4.1; python_version >= "3"
  Downloading scipy-1.4.1-cp36-cp36m-manylinux1_x86_64.whl (26.1 MB)
Collecting opt-einsum>=2.3.2
  Downloading opt_einsum-3.2.1-py3-none-any.whl (63 kB)
Collecting protobuf>=3.8.0
  Downloading protobuf-3.12.2-cp36-cp36m-manylinux1_x86_64.whl (1.3 MB)
Collecting numpy<2.0,>=1.16.0
  Downloading numpy-1.19.0-cp36-cp36m-manylinux2010_x86_64.whl (14.6 MB)
Collecting gast==0.2.2
  Downloading gast-0.2.2.tar.gz (10 kB)
Collecting termcolor>=1.1.0
  Downloading termcolor-1.1.0.tar.gz (3.9 kB)
Collecting tensorflow-estimator<2.2.0,>=2.1.0rc0
  Downloading tensorflow_estimator-2.1.0-py2.py3-none-any.whl (448 kB)
Collecting h5py
  Downloading h5py-2.10.0-cp36-cp36m-manylinux1_x86_64.whl (2.9 MB)
Collecting markdown>=2.6.8
  Downloading Markdown-3.2.2-py3-none-any.whl (88 kB)
Collecting google-auth-oauthlib<0.5,>=0.4.1
  Downloading google_auth_oauthlib-0.4.1-py2.py3-none-any.whl (18 kB)
Collecting werkzeug>=0.11.15
  Downloading Werkzeug-1.0.1-py2.py3-none-any.whl (298 kB)
Requirement already satisfied: requests<3,>=2.21.0 in /opt/conda/lib/python3.6/site-packages (from tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (2.24.0)
Requirement already satisfied: setuptools>=41.0.0 in /opt/conda/lib/python3.6/site-packages (from tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (49.2.0.post20200714)
Collecting google-auth<2,>=1.6.3
  Downloading google_auth-1.19.0-py2.py3-none-any.whl (91 kB)
Collecting importlib-metadata; python_version < "3.8"
  Downloading importlib_metadata-1.7.0-py2.py3-none-any.whl (31 kB)
Collecting requests-oauthlib>=0.7.0
  Downloading requests_oauthlib-1.3.0-py2.py3-none-any.whl (23 kB)
Requirement already satisfied: chardet<4,>=3.0.2 in /opt/conda/lib/python3.6/site-packages (from requests<3,>=2.21.0->tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (3.0.4)
Requirement already satisfied: idna<3,>=2.5 in /opt/conda/lib/python3.6/site-packages (from requests<3,>=2.21.0->tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (2.10)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /opt/conda/lib/python3.6/site-packages (from requests<3,>=2.21.0->tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (1.25.9)
Requirement already satisfied: certifi>=2017.4.17 in /opt/conda/lib/python3.6/site-packages (from requests<3,>=2.21.0->tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (2020.6.20)
Collecting rsa<5,>=3.1.4; python_version >= "3"
  Downloading rsa-4.6-py3-none-any.whl (47 kB)
Collecting cachetools<5.0,>=2.0.0
  Downloading cachetools-4.1.1-py3-none-any.whl (10 kB)
Collecting pyasn1-modules>=0.2.1
  Downloading pyasn1_modules-0.2.8-py2.py3-none-any.whl (155 kB)
Collecting zipp>=0.5
  Downloading zipp-3.1.0-py3-none-any.whl (4.9 kB)
Collecting oauthlib>=3.0.0
  Downloading oauthlib-3.1.0-py2.py3-none-any.whl (147 kB)
Collecting pyasn1>=0.1.3
  Downloading pyasn1-0.4.8-py2.py3-none-any.whl (77 kB)
Building wheels for collected packages: wrapt, absl-py, gast, termcolor
  Building wheel for wrapt (setup.py): started
  Building wheel for wrapt (setup.py): finished with status 'done'
  Created wheel for wrapt: filename=wrapt-1.12.1-cp36-cp36m-linux_x86_64.whl size=69692 sha256=771966dc30d62785ac5a8cd2c03cbbafe1cd593a2f65631009e4b75fd19330e8
  Stored in directory: /root/.cache/pip/wheels/32/42/7f/23cae9ff6ef66798d00dc5d659088e57dbba01566f6c60db63
  Building wheel for absl-py (setup.py): started
  Building wheel for absl-py (setup.py): finished with status 'done'
  Created wheel for absl-py: filename=absl_py-0.9.0-py3-none-any.whl size=121931 sha256=b80dd46ecd781cf5ffe7e0482edf2125b9455dc3dc829055ccbe77cb63e32e9f
  Stored in directory: /root/.cache/pip/wheels/c3/af/84/3962a6af7b4ab336e951b7877dcfb758cf94548bb1771e0679
  Building wheel for gast (setup.py): started
  Building wheel for gast (setup.py): finished with status 'done'
  Created wheel for gast: filename=gast-0.2.2-py3-none-any.whl size=7539 sha256=cfb7751b182fe6b57ad905b2ffd9c9fcf1b6d5093bb639c1946b745e7084b101
  Stored in directory: /root/.cache/pip/wheels/19/a7/b9/0740c7a3a7d1d348f04823339274b90de25fbcd217b2ee1fbe
  Building wheel for termcolor (setup.py): started
  Building wheel for termcolor (setup.py): finished with status 'done'
  Created wheel for termcolor: filename=termcolor-1.1.0-py3-none-any.whl size=4830 sha256=b7204f224b19da14595f902f07292935d322d721b1ca3a569b525616a0dea947
  Stored in directory: /root/.cache/pip/wheels/93/2a/eb/e58dbcbc963549ee4f065ff80a59f274cc7210b6eab962acdc
Successfully built wrapt absl-py gast termcolor
Installing collected packages: astor, numpy, h5py, keras-applications, zipp, importlib-metadata, markdown, oauthlib, requests-oauthlib, pyasn1, rsa, cachetools, pyasn1-modules, google-auth, google-auth-oauthlib, werkzeug, absl-py, grpcio, protobuf, tensorboard, wrapt, keras-preprocessing, google-pasta, scipy, opt-einsum, gast, termcolor, tensorflow-estimator, tensorflow-cpu
  Attempting uninstall: numpy
    Found existing installation: numpy 1.15.4
    Uninstalling numpy-1.15.4:
      Successfully uninstalled numpy-1.15.4
Successfully installed absl-py-0.9.0 astor-0.8.1 cachetools-4.1.1 gast-0.2.2 google-auth-1.19.0 google-auth-oauthlib-0.4.1 google-pasta-0.2.0 grpcio-1.30.0 h5py-2.10.0 importlib-metadata-1.7.0 keras-applications-1.0.8 keras-preprocessing-1.1.2 markdown-3.2.2 numpy-1.19.0 oauthlib-3.1.0 opt-einsum-3.2.1 protobuf-3.12.2 pyasn1-0.4.8 pyasn1-modules-0.2.8 requests-oauthlib-1.3.0 rsa-4.6 scipy-1.4.1 tensorboard-2.1.1 tensorflow-cpu-2.1.0 tensorflow-estimator-2.1.0 termcolor-1.1.0 werkzeug-1.0.1 wrapt-1.12.1 zipp-3.1.0
Removing intermediate container f45a9267ade7
 ---> c2722680adef
Step 5/13 : COPY requirements.txt .
 ---> d735cc5a16ad
Step 6/13 : RUN pip install -r requirements.txt
 ---> Running in 8cd357aaf7f6
Collecting ConfigSpace==0.4.10
  Downloading ConfigSpace-0.4.10.tar.gz (882 kB)
Collecting bayesian-optimization
  Downloading bayesian-optimization-1.2.0.tar.gz (14 kB)
Collecting boto3
  Downloading boto3-1.14.20-py2.py3-none-any.whl (128 kB)
Collecting dm_tree
  Downloading dm_tree-0.1.5-cp36-cp36m-manylinux1_x86_64.whl (294 kB)
Collecting dragonfly-opt
  Downloading dragonfly-opt-0.1.6.tar.gz (252 kB)
Collecting gym[atari]
  Downloading gym-0.17.2.tar.gz (1.6 MB)
Requirement already satisfied: h5py in /opt/conda/lib/python3.6/site-packages (from -r requirements.txt (line 7)) (2.10.0)
Collecting hpbandster
  Downloading hpbandster-0.7.4.tar.gz (51 kB)
Collecting hyperopt==0.1.2
  Downloading hyperopt-0.1.2-py3-none-any.whl (115 kB)
Collecting jupyter
  Downloading jupyter-1.0.0-py2.py3-none-any.whl (2.7 kB)
Collecting keras
  Downloading Keras-2.4.3-py2.py3-none-any.whl (36 kB)
Collecting lightgbm
  Downloading lightgbm-2.3.1-py2.py3-none-manylinux1_x86_64.whl (1.2 MB)
Collecting lz4
  Downloading lz4-3.1.0-cp36-cp36m-manylinux2010_x86_64.whl (1.8 MB)
Collecting matplotlib
  Downloading matplotlib-3.2.2-cp36-cp36m-manylinux1_x86_64.whl (12.4 MB)
Collecting mlflow
  Downloading mlflow-1.9.1-py3-none-any.whl (11.9 MB)
Collecting nevergrad
  Downloading nevergrad-0.4.1.post4-py3-none-any.whl (263 kB)
Collecting opencv-python-headless
  Downloading opencv_python_headless-4.3.0.36-cp36-cp36m-manylinux2014_x86_64.whl (36.4 MB)
Collecting pandas
  Downloading pandas-1.0.5-cp36-cp36m-manylinux1_x86_64.whl (10.1 MB)
Collecting pytest-remotedata>=0.3.1
  Downloading pytest_remotedata-0.3.2-py2.py3-none-any.whl (8.3 kB)
Collecting pytest-timeout
  Downloading pytest_timeout-1.4.1-py2.py3-none-any.whl (10 kB)
Collecting pytorch-lightning
  Downloading pytorch_lightning-0.8.5-py3-none-any.whl (313 kB)
Collecting scikit-learn==0.22.2
  Downloading scikit_learn-0.22.2-cp36-cp36m-manylinux1_x86_64.whl (7.1 MB)
Collecting scikit-optimize
  Downloading scikit_optimize-0.7.4-py2.py3-none-any.whl (80 kB)
Collecting sigopt
  Downloading sigopt-5.7.0-py2.py3-none-any.whl (20 kB)
Collecting smart_open
  Downloading smart_open-2.1.0.tar.gz (116 kB)
Collecting tabulate
  Downloading tabulate-0.8.7-py3-none-any.whl (24 kB)
Collecting tensorboardX
  Downloading tensorboardX-2.1-py2.py3-none-any.whl (308 kB)
Collecting tensorflow_probability
  Downloading tensorflow_probability-0.10.1-py2.py3-none-any.whl (3.5 MB)
Requirement already satisfied: torch in /opt/conda/lib/python3.6/site-packages (from -r requirements.txt (line 29)) (1.4.0+cpu)
Requirement already satisfied: torchvision in /opt/conda/lib/python3.6/site-packages (from -r requirements.txt (line 30)) (0.5.0+cpu)
Collecting xgboost
  Downloading xgboost-1.1.1-py3-none-manylinux2010_x86_64.whl (127.6 MB)
Collecting zoopt>=0.4.0
  Downloading zoopt-0.4.0-py2.py3-none-any.whl (57 kB)
Collecting timm
  Downloading timm-0.1.30-py3-none-any.whl (207 kB)
Collecting dataclasses
  Downloading dataclasses-0.7-py3-none-any.whl (18 kB)
ERROR: Could not find a version that satisfies the requirement tune-sklearn==0.0.5 (from -r requirements.txt (line 35)) (from versions: 0.0.0, 0.0.1, 0.0.2, 0.0.3, 0.0.4)
ERROR: No matching distribution found for tune-sklearn==0.0.5 (from -r requirements.txt (line 35))
The command '/bin/sh -c pip install -r requirements.txt' returned a non-zero code: 1
+ DOCKER_SHA=
+ [[ 1 -lt 3 ]]
+ (( n++ ))
+ echo 'Command failed. Attempt 2/3:'
Command failed. Attempt 2/3:
+ true
+ bash /home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests/run_tune_tests.sh 8G 4G
+ MEMORY_SIZE=8G
+ SHM_SIZE=4G
+ DOCKER_SHA=
+++ dirname /home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests/run_tune_tests.sh
++ cd /home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests
++ pwd
+ ROOT_DIR=/home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests
+ SUPPRESS_OUTPUT=/home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests/../suppress_output
+ '[' 8G == '' ']'
+ '[' 4G == '' ']'
+ '[' '' == '' ']'
+ echo 'Building application docker.'
Building application docker.
+ docker build -q --no-cache -t ray-project/base-deps docker/base-deps
sha256:c07ab7f93dcc94804d642f8c77d92fcb95a73bb74656ae318c959eb08812c23d
+ git rev-parse HEAD
++ git rev-parse HEAD
+ git archive -o ./docker/tune_test/ray.tar 7eacf677a29a8a318959e53f14c2f936b98a7520
+ '[' 1 == 1 ']'
++ docker build --no-cache -q -t ray-project/tune_test docker/tune_test -f docker/tune_test/build_from_source.Dockerfile
Sending build context to Docker daemon  64.55MB

Step 1/13 : FROM ray-project/base-deps
 ---> c07ab7f93dcc
Step 2/13 : RUN pip install -U pip
 ---> Running in d5b0e5a8e349
Requirement already up-to-date: pip in /opt/conda/lib/python3.6/site-packages (20.1.1)
Removing intermediate container d5b0e5a8e349
 ---> 551d7ca7d07d
Step 3/13 : RUN pip install torch==1.4.0+cpu torchvision==0.5.0+cpu -f https://download.pytorch.org/whl/torch_stable.html
 ---> Running in 3fd01bbd3911
Looking in links: https://download.pytorch.org/whl/torch_stable.html
Collecting torch==1.4.0+cpu
  Downloading https://download.pytorch.org/whl/cpu/torch-1.4.0%2Bcpu-cp36-cp36m-linux_x86_64.whl (127.2 MB)
Collecting torchvision==0.5.0+cpu
  Downloading https://download.pytorch.org/whl/cpu/torchvision-0.5.0%2Bcpu-cp36-cp36m-linux_x86_64.whl (5.4 MB)
Requirement already satisfied: six in /opt/conda/lib/python3.6/site-packages (from torchvision==0.5.0+cpu) (1.15.0)
Collecting pillow>=4.1.1
  Downloading Pillow-7.2.0-cp36-cp36m-manylinux1_x86_64.whl (2.2 MB)
Requirement already satisfied: numpy in /opt/conda/lib/python3.6/site-packages (from torchvision==0.5.0+cpu) (1.15.4)
Installing collected packages: torch, pillow, torchvision
Successfully installed pillow-7.2.0 torch-1.4.0+cpu torchvision-0.5.0+cpu
Removing intermediate container 3fd01bbd3911
 ---> 5b27444e070a
Step 4/13 : RUN pip install https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow_cpu-2.1.0-cp36-cp36m-manylinux2010_x86_64.whl
 ---> Running in c6dae5bc503f
Collecting tensorflow-cpu==2.1.0
  Downloading https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow_cpu-2.1.0-cp36-cp36m-manylinux2010_x86_64.whl (104.6 MB)
Collecting termcolor>=1.1.0
  Downloading termcolor-1.1.0.tar.gz (3.9 kB)
Collecting absl-py>=0.7.0
  Downloading absl-py-0.9.0.tar.gz (104 kB)
Collecting protobuf>=3.8.0
  Downloading protobuf-3.12.2-cp36-cp36m-manylinux1_x86_64.whl (1.3 MB)
Collecting tensorflow-estimator<2.2.0,>=2.1.0rc0
  Downloading tensorflow_estimator-2.1.0-py2.py3-none-any.whl (448 kB)
Collecting keras-applications>=1.0.8
  Downloading Keras_Applications-1.0.8-py3-none-any.whl (50 kB)
Collecting grpcio>=1.8.6
  Downloading grpcio-1.30.0-cp36-cp36m-manylinux2010_x86_64.whl (3.0 MB)
Collecting numpy<2.0,>=1.16.0
  Downloading numpy-1.19.0-cp36-cp36m-manylinux2010_x86_64.whl (14.6 MB)
Collecting tensorboard<2.2.0,>=2.1.0
  Downloading tensorboard-2.1.1-py3-none-any.whl (3.8 MB)
Collecting astor>=0.6.0
  Downloading astor-0.8.1-py2.py3-none-any.whl (27 kB)
Collecting google-pasta>=0.1.6
  Downloading google_pasta-0.2.0-py3-none-any.whl (57 kB)
Collecting gast==0.2.2
  Downloading gast-0.2.2.tar.gz (10 kB)
Collecting keras-preprocessing>=1.1.0
  Downloading Keras_Preprocessing-1.1.2-py2.py3-none-any.whl (42 kB)
Requirement already satisfied: six>=1.12.0 in /opt/conda/lib/python3.6/site-packages (from tensorflow-cpu==2.1.0) (1.15.0)
Collecting scipy==1.4.1; python_version >= "3"
  Downloading scipy-1.4.1-cp36-cp36m-manylinux1_x86_64.whl (26.1 MB)
Requirement already satisfied: wheel>=0.26; python_version >= "3" in /opt/conda/lib/python3.6/site-packages (from tensorflow-cpu==2.1.0) (0.34.2)
Collecting opt-einsum>=2.3.2
  Downloading opt_einsum-3.2.1-py3-none-any.whl (63 kB)
Collecting wrapt>=1.11.1
  Downloading wrapt-1.12.1.tar.gz (27 kB)
Requirement already satisfied: setuptools in /opt/conda/lib/python3.6/site-packages (from protobuf>=3.8.0->tensorflow-cpu==2.1.0) (49.2.0.post20200714)
Collecting h5py
  Downloading h5py-2.10.0-cp36-cp36m-manylinux1_x86_64.whl (2.9 MB)
Requirement already satisfied: requests<3,>=2.21.0 in /opt/conda/lib/python3.6/site-packages (from tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (2.24.0)
Collecting google-auth<2,>=1.6.3
  Downloading google_auth-1.19.0-py2.py3-none-any.whl (91 kB)
Collecting markdown>=2.6.8
  Downloading Markdown-3.2.2-py3-none-any.whl (88 kB)
Collecting werkzeug>=0.11.15
  Downloading Werkzeug-1.0.1-py2.py3-none-any.whl (298 kB)
Collecting google-auth-oauthlib<0.5,>=0.4.1
  Downloading google_auth_oauthlib-0.4.1-py2.py3-none-any.whl (18 kB)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /opt/conda/lib/python3.6/site-packages (from requests<3,>=2.21.0->tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (1.25.9)
Requirement already satisfied: chardet<4,>=3.0.2 in /opt/conda/lib/python3.6/site-packages (from requests<3,>=2.21.0->tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (3.0.4)
Requirement already satisfied: certifi>=2017.4.17 in /opt/conda/lib/python3.6/site-packages (from requests<3,>=2.21.0->tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (2020.6.20)
Requirement already satisfied: idna<3,>=2.5 in /opt/conda/lib/python3.6/site-packages (from requests<3,>=2.21.0->tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (2.10)
Collecting pyasn1-modules>=0.2.1
  Downloading pyasn1_modules-0.2.8-py2.py3-none-any.whl (155 kB)
Collecting rsa<5,>=3.1.4; python_version >= "3"
  Downloading rsa-4.6-py3-none-any.whl (47 kB)
Collecting cachetools<5.0,>=2.0.0
  Downloading cachetools-4.1.1-py3-none-any.whl (10 kB)
Collecting importlib-metadata; python_version < "3.8"
  Downloading importlib_metadata-1.7.0-py2.py3-none-any.whl (31 kB)
Collecting requests-oauthlib>=0.7.0
  Downloading requests_oauthlib-1.3.0-py2.py3-none-any.whl (23 kB)
Collecting pyasn1<0.5.0,>=0.4.6
  Downloading pyasn1-0.4.8-py2.py3-none-any.whl (77 kB)
Collecting zipp>=0.5
  Downloading zipp-3.1.0-py3-none-any.whl (4.9 kB)
Collecting oauthlib>=3.0.0
  Downloading oauthlib-3.1.0-py2.py3-none-any.whl (147 kB)
Building wheels for collected packages: termcolor, absl-py, gast, wrapt
  Building wheel for termcolor (setup.py): started
  Building wheel for termcolor (setup.py): finished with status 'done'
  Created wheel for termcolor: filename=termcolor-1.1.0-py3-none-any.whl size=4830 sha256=e11b509646ee2c97f60999c301455d0ecac144cf66fe3040187f4e9f7422fa0e
  Stored in directory: /root/.cache/pip/wheels/93/2a/eb/e58dbcbc963549ee4f065ff80a59f274cc7210b6eab962acdc
  Building wheel for absl-py (setup.py): started
  Building wheel for absl-py (setup.py): finished with status 'done'
  Created wheel for absl-py: filename=absl_py-0.9.0-py3-none-any.whl size=121931 sha256=2044cc3471444061c867d527e9babe8af16a608b4dcd4ae06f3464b4ca7da40c
  Stored in directory: /root/.cache/pip/wheels/c3/af/84/3962a6af7b4ab336e951b7877dcfb758cf94548bb1771e0679
  Building wheel for gast (setup.py): started
  Building wheel for gast (setup.py): finished with status 'done'
  Created wheel for gast: filename=gast-0.2.2-py3-none-any.whl size=7539 sha256=fb666ff86214d41097523361fe1b30d99e36541220437d676968fadcc06ba2e5
  Stored in directory: /root/.cache/pip/wheels/19/a7/b9/0740c7a3a7d1d348f04823339274b90de25fbcd217b2ee1fbe
  Building wheel for wrapt (setup.py): started
  Building wheel for wrapt (setup.py): finished with status 'done'
  Created wheel for wrapt: filename=wrapt-1.12.1-cp36-cp36m-linux_x86_64.whl size=69684 sha256=7d758f35924617ffd5f3179f110c7bae9179273b4b0254519f86c773812ff617
  Stored in directory: /root/.cache/pip/wheels/32/42/7f/23cae9ff6ef66798d00dc5d659088e57dbba01566f6c60db63
Successfully built termcolor absl-py gast wrapt
Installing collected packages: termcolor, absl-py, protobuf, tensorflow-estimator, numpy, h5py, keras-applications, grpcio, pyasn1, pyasn1-modules, rsa, cachetools, google-auth, zipp, importlib-metadata, markdown, werkzeug, oauthlib, requests-oauthlib, google-auth-oauthlib, tensorboard, astor, google-pasta, gast, keras-preprocessing, scipy, opt-einsum, wrapt, tensorflow-cpu
  Attempting uninstall: numpy
    Found existing installation: numpy 1.15.4
    Uninstalling numpy-1.15.4:
      Successfully uninstalled numpy-1.15.4
Successfully installed absl-py-0.9.0 astor-0.8.1 cachetools-4.1.1 gast-0.2.2 google-auth-1.19.0 google-auth-oauthlib-0.4.1 google-pasta-0.2.0 grpcio-1.30.0 h5py-2.10.0 importlib-metadata-1.7.0 keras-applications-1.0.8 keras-preprocessing-1.1.2 markdown-3.2.2 numpy-1.19.0 oauthlib-3.1.0 opt-einsum-3.2.1 protobuf-3.12.2 pyasn1-0.4.8 pyasn1-modules-0.2.8 requests-oauthlib-1.3.0 rsa-4.6 scipy-1.4.1 tensorboard-2.1.1 tensorflow-cpu-2.1.0 tensorflow-estimator-2.1.0 termcolor-1.1.0 werkzeug-1.0.1 wrapt-1.12.1 zipp-3.1.0
Removing intermediate container c6dae5bc503f
 ---> 3951a37b6d64
Step 5/13 : COPY requirements.txt .
 ---> ad87f35de56a
Step 6/13 : RUN pip install -r requirements.txt
 ---> Running in f006e60478a6
Collecting ConfigSpace==0.4.10
  Downloading ConfigSpace-0.4.10.tar.gz (882 kB)
Collecting bayesian-optimization
  Downloading bayesian-optimization-1.2.0.tar.gz (14 kB)
Collecting boto3
  Downloading boto3-1.14.20-py2.py3-none-any.whl (128 kB)
Collecting dm_tree
  Downloading dm_tree-0.1.5-cp36-cp36m-manylinux1_x86_64.whl (294 kB)
Collecting dragonfly-opt
  Downloading dragonfly-opt-0.1.6.tar.gz (252 kB)
Collecting gym[atari]
  Downloading gym-0.17.2.tar.gz (1.6 MB)
Requirement already satisfied: h5py in /opt/conda/lib/python3.6/site-packages (from -r requirements.txt (line 7)) (2.10.0)
Collecting hpbandster
  Downloading hpbandster-0.7.4.tar.gz (51 kB)
Collecting hyperopt==0.1.2
  Downloading hyperopt-0.1.2-py3-none-any.whl (115 kB)
Collecting jupyter
  Downloading jupyter-1.0.0-py2.py3-none-any.whl (2.7 kB)
Collecting keras
  Downloading Keras-2.4.3-py2.py3-none-any.whl (36 kB)
Collecting lightgbm
  Downloading lightgbm-2.3.1-py2.py3-none-manylinux1_x86_64.whl (1.2 MB)
Collecting lz4
  Downloading lz4-3.1.0-cp36-cp36m-manylinux2010_x86_64.whl (1.8 MB)
Collecting matplotlib
  Downloading matplotlib-3.2.2-cp36-cp36m-manylinux1_x86_64.whl (12.4 MB)
Collecting mlflow
  Downloading mlflow-1.9.1-py3-none-any.whl (11.9 MB)
Collecting nevergrad
  Downloading nevergrad-0.4.1.post4-py3-none-any.whl (263 kB)
Collecting opencv-python-headless
  Downloading opencv_python_headless-4.3.0.36-cp36-cp36m-manylinux2014_x86_64.whl (36.4 MB)
Collecting pandas
  Downloading pandas-1.0.5-cp36-cp36m-manylinux1_x86_64.whl (10.1 MB)
Collecting pytest-remotedata>=0.3.1
  Downloading pytest_remotedata-0.3.2-py2.py3-none-any.whl (8.3 kB)
Collecting pytest-timeout
  Downloading pytest_timeout-1.4.1-py2.py3-none-any.whl (10 kB)
Collecting pytorch-lightning
  Downloading pytorch_lightning-0.8.5-py3-none-any.whl (313 kB)
Collecting scikit-learn==0.22.2
  Downloading scikit_learn-0.22.2-cp36-cp36m-manylinux1_x86_64.whl (7.1 MB)
Collecting scikit-optimize
  Downloading scikit_optimize-0.7.4-py2.py3-none-any.whl (80 kB)
Collecting sigopt
  Downloading sigopt-5.7.0-py2.py3-none-any.whl (20 kB)
Collecting smart_open
  Downloading smart_open-2.1.0.tar.gz (116 kB)
Collecting tabulate
  Downloading tabulate-0.8.7-py3-none-any.whl (24 kB)
Collecting tensorboardX
  Downloading tensorboardX-2.1-py2.py3-none-any.whl (308 kB)
Collecting tensorflow_probability
  Downloading tensorflow_probability-0.10.1-py2.py3-none-any.whl (3.5 MB)
Requirement already satisfied: torch in /opt/conda/lib/python3.6/site-packages (from -r requirements.txt (line 29)) (1.4.0+cpu)
Requirement already satisfied: torchvision in /opt/conda/lib/python3.6/site-packages (from -r requirements.txt (line 30)) (0.5.0+cpu)
Collecting xgboost
  Downloading xgboost-1.1.1-py3-none-manylinux2010_x86_64.whl (127.6 MB)
Collecting zoopt>=0.4.0
  Downloading zoopt-0.4.0-py2.py3-none-any.whl (57 kB)
Collecting timm
  Downloading timm-0.1.30-py3-none-any.whl (207 kB)
Collecting dataclasses
  Downloading dataclasses-0.7-py3-none-any.whl (18 kB)
ERROR: Could not find a version that satisfies the requirement tune-sklearn==0.0.5 (from -r requirements.txt (line 35)) (from versions: 0.0.0, 0.0.1, 0.0.2, 0.0.3, 0.0.4)
ERROR: No matching distribution found for tune-sklearn==0.0.5 (from -r requirements.txt (line 35))
The command '/bin/sh -c pip install -r requirements.txt' returned a non-zero code: 1
+ DOCKER_SHA=
+ [[ 2 -lt 3 ]]
+ (( n++ ))
+ echo 'Command failed. Attempt 3/3:'
Command failed. Attempt 3/3:
+ true
+ bash /home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests/run_tune_tests.sh 8G 4G
+ MEMORY_SIZE=8G
+ SHM_SIZE=4G
+ DOCKER_SHA=
+++ dirname /home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests/run_tune_tests.sh
++ cd /home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests
++ pwd
+ ROOT_DIR=/home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests
+ SUPPRESS_OUTPUT=/home/jenkins/workspace/Ray-PRB@3/ci/jenkins_tests/../suppress_output
+ '[' 8G == '' ']'
+ '[' 4G == '' ']'
+ '[' '' == '' ']'
+ echo 'Building application docker.'
Building application docker.
+ docker build -q --no-cache -t ray-project/base-deps docker/base-deps
sha256:99cb70fc9f9278a23abbdbe94288f86cc27327e024cba41ecaaf3cd6faa119b9
+ git rev-parse HEAD
++ git rev-parse HEAD
+ git archive -o ./docker/tune_test/ray.tar 7eacf677a29a8a318959e53f14c2f936b98a7520
+ '[' 1 == 1 ']'
++ docker build --no-cache -q -t ray-project/tune_test docker/tune_test -f docker/tune_test/build_from_source.Dockerfile
Sending build context to Docker daemon  64.55MB

Step 1/13 : FROM ray-project/base-deps
 ---> 99cb70fc9f92
Step 2/13 : RUN pip install -U pip
 ---> Running in b11b8704d3ba
Requirement already up-to-date: pip in /opt/conda/lib/python3.6/site-packages (20.1.1)
Removing intermediate container b11b8704d3ba
 ---> 29d8a03a4b38
Step 3/13 : RUN pip install torch==1.4.0+cpu torchvision==0.5.0+cpu -f https://download.pytorch.org/whl/torch_stable.html
 ---> Running in adea95e5db68
Looking in links: https://download.pytorch.org/whl/torch_stable.html
Collecting torch==1.4.0+cpu
  Downloading https://download.pytorch.org/whl/cpu/torch-1.4.0%2Bcpu-cp36-cp36m-linux_x86_64.whl (127.2 MB)
Collecting torchvision==0.5.0+cpu
  Downloading https://download.pytorch.org/whl/cpu/torchvision-0.5.0%2Bcpu-cp36-cp36m-linux_x86_64.whl (5.4 MB)
Collecting pillow>=4.1.1
  Downloading Pillow-7.2.0-cp36-cp36m-manylinux1_x86_64.whl (2.2 MB)
Requirement already satisfied: six in /opt/conda/lib/python3.6/site-packages (from torchvision==0.5.0+cpu) (1.15.0)
Requirement already satisfied: numpy in /opt/conda/lib/python3.6/site-packages (from torchvision==0.5.0+cpu) (1.15.4)
Installing collected packages: torch, pillow, torchvision
Successfully installed pillow-7.2.0 torch-1.4.0+cpu torchvision-0.5.0+cpu
Removing intermediate container adea95e5db68
 ---> 9271e31beef2
Step 4/13 : RUN pip install https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow_cpu-2.1.0-cp36-cp36m-manylinux2010_x86_64.whl
 ---> Running in 9cb79ea186fa
Collecting tensorflow-cpu==2.1.0
  Downloading https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow_cpu-2.1.0-cp36-cp36m-manylinux2010_x86_64.whl (104.6 MB)
Collecting grpcio>=1.8.6
  Downloading grpcio-1.30.0-cp36-cp36m-manylinux2010_x86_64.whl (3.0 MB)
Collecting numpy<2.0,>=1.16.0
  Downloading numpy-1.19.0-cp36-cp36m-manylinux2010_x86_64.whl (14.6 MB)
Collecting astor>=0.6.0
  Downloading astor-0.8.1-py2.py3-none-any.whl (27 kB)
Collecting keras-preprocessing>=1.1.0
  Downloading Keras_Preprocessing-1.1.2-py2.py3-none-any.whl (42 kB)
Collecting opt-einsum>=2.3.2
  Downloading opt_einsum-3.2.1-py3-none-any.whl (63 kB)
Collecting absl-py>=0.7.0
  Downloading absl-py-0.9.0.tar.gz (104 kB)
Collecting protobuf>=3.8.0
  Downloading protobuf-3.12.2-cp36-cp36m-manylinux1_x86_64.whl (1.3 MB)
Collecting scipy==1.4.1; python_version >= "3"
  Downloading scipy-1.4.1-cp36-cp36m-manylinux1_x86_64.whl (26.1 MB)
Collecting gast==0.2.2
  Downloading gast-0.2.2.tar.gz (10 kB)
Collecting tensorboard<2.2.0,>=2.1.0
  Downloading tensorboard-2.1.1-py3-none-any.whl (3.8 MB)
Collecting keras-applications>=1.0.8
  Downloading Keras_Applications-1.0.8-py3-none-any.whl (50 kB)
Collecting termcolor>=1.1.0
  Downloading termcolor-1.1.0.tar.gz (3.9 kB)
Collecting tensorflow-estimator<2.2.0,>=2.1.0rc0
  Downloading tensorflow_estimator-2.1.0-py2.py3-none-any.whl (448 kB)
Collecting wrapt>=1.11.1
  Downloading wrapt-1.12.1.tar.gz (27 kB)
Requirement already satisfied: six>=1.12.0 in /opt/conda/lib/python3.6/site-packages (from tensorflow-cpu==2.1.0) (1.15.0)
Requirement already satisfied: wheel>=0.26; python_version >= "3" in /opt/conda/lib/python3.6/site-packages (from tensorflow-cpu==2.1.0) (0.34.2)
Collecting google-pasta>=0.1.6
  Downloading google_pasta-0.2.0-py3-none-any.whl (57 kB)
Requirement already satisfied: setuptools in /opt/conda/lib/python3.6/site-packages (from protobuf>=3.8.0->tensorflow-cpu==2.1.0) (49.2.0.post20200714)
Collecting werkzeug>=0.11.15
  Downloading Werkzeug-1.0.1-py2.py3-none-any.whl (298 kB)
Collecting markdown>=2.6.8
  Downloading Markdown-3.2.2-py3-none-any.whl (88 kB)
Collecting google-auth-oauthlib<0.5,>=0.4.1
  Downloading google_auth_oauthlib-0.4.1-py2.py3-none-any.whl (18 kB)
Requirement already satisfied: requests<3,>=2.21.0 in /opt/conda/lib/python3.6/site-packages (from tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (2.24.0)
Collecting google-auth<2,>=1.6.3
  Downloading google_auth-1.19.0-py2.py3-none-any.whl (91 kB)
Collecting h5py
  Downloading h5py-2.10.0-cp36-cp36m-manylinux1_x86_64.whl (2.9 MB)
Collecting importlib-metadata; python_version < "3.8"
  Downloading importlib_metadata-1.7.0-py2.py3-none-any.whl (31 kB)
Collecting requests-oauthlib>=0.7.0
  Downloading requests_oauthlib-1.3.0-py2.py3-none-any.whl (23 kB)
Requirement already satisfied: chardet<4,>=3.0.2 in /opt/conda/lib/python3.6/site-packages (from requests<3,>=2.21.0->tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (3.0.4)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /opt/conda/lib/python3.6/site-packages (from requests<3,>=2.21.0->tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (1.25.9)
Requirement already satisfied: certifi>=2017.4.17 in /opt/conda/lib/python3.6/site-packages (from requests<3,>=2.21.0->tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (2020.6.20)
Requirement already satisfied: idna<3,>=2.5 in /opt/conda/lib/python3.6/site-packages (from requests<3,>=2.21.0->tensorboard<2.2.0,>=2.1.0->tensorflow-cpu==2.1.0) (2.10)
Collecting rsa<5,>=3.1.4; python_version >= "3"
  Downloading rsa-4.6-py3-none-any.whl (47 kB)
Collecting pyasn1-modules>=0.2.1
  Downloading pyasn1_modules-0.2.8-py2.py3-none-any.whl (155 kB)
Collecting cachetools<5.0,>=2.0.0
  Downloading cachetools-4.1.1-py3-none-any.whl (10 kB)
Collecting zipp>=0.5
  Downloading zipp-3.1.0-py3-none-any.whl (4.9 kB)
Collecting oauthlib>=3.0.0
  Downloading oauthlib-3.1.0-py2.py3-none-any.whl (147 kB)
Collecting pyasn1>=0.1.3
  Downloading pyasn1-0.4.8-py2.py3-none-any.whl (77 kB)
Building wheels for collected packages: absl-py, gast, termcolor, wrapt
  Building wheel for absl-py (setup.py): started
  Building wheel for absl-py (setup.py): finished with status 'done'
  Created wheel for absl-py: filename=absl_py-0.9.0-py3-none-any.whl size=121931 sha256=e75c6d191932f9964b42ccfc7c667d7d281825e464848565037a7dd8ec99cb6a
  Stored in directory: /root/.cache/pip/wheels/c3/af/84/3962a6af7b4ab336e951b7877dcfb758cf94548bb1771e0679
  Building wheel for gast (setup.py): started
  Building wheel for gast (setup.py): finished with status 'done'
  Created wheel for gast: filename=gast-0.2.2-py3-none-any.whl size=7539 sha256=22dbda7470ecf17abc230b26eb74f607d00210fcd5c2b897a3989964cd7071ca
  Stored in directory: /root/.cache/pip/wheels/19/a7/b9/0740c7a3a7d1d348f04823339274b90de25fbcd217b2ee1fbe
  Building wheel for termcolor (setup.py): started
  Building wheel for termcolor (setup.py): finished with status 'done'
  Created wheel for termcolor: filename=termcolor-1.1.0-py3-none-any.whl size=4830 sha256=fc1f7cce0995614c6c90205bcf8ca5f8b33afd3d10548e7b289ee124daf5b003
  Stored in directory: /root/.cache/pip/wheels/93/2a/eb/e58dbcbc963549ee4f065ff80a59f274cc7210b6eab962acdc
  Building wheel for wrapt (setup.py): started
  Building wheel for wrapt (setup.py): finished with status 'done'
  Created wheel for wrapt: filename=wrapt-1.12.1-cp36-cp36m-linux_x86_64.whl size=69691 sha256=942b485c20a6807db9e546e508457f2bcd2d16363e53ed3d05b854aa62d05016
  Stored in directory: /root/.cache/pip/wheels/32/42/7f/23cae9ff6ef66798d00dc5d659088e57dbba01566f6c60db63
Successfully built absl-py gast termcolor wrapt
Installing collected packages: grpcio, numpy, astor, keras-preprocessing, opt-einsum, absl-py, protobuf, scipy, gast, werkzeug, zipp, importlib-metadata, markdown, pyasn1, rsa, pyasn1-modules, cachetools, google-auth, oauthlib, requests-oauthlib, google-auth-oauthlib, tensorboard, h5py, keras-applications, termcolor, tensorflow-estimator, wrapt, google-pasta, tensorflow-cpu
  Attempting uninstall: numpy
    Found existing installation: numpy 1.15.4
    Uninstalling numpy-1.15.4:
      Successfully uninstalled numpy-1.15.4
Successfully installed absl-py-0.9.0 astor-0.8.1 cachetools-4.1.1 gast-0.2.2 google-auth-1.19.0 google-auth-oauthlib-0.4.1 google-pasta-0.2.0 grpcio-1.30.0 h5py-2.10.0 importlib-metadata-1.7.0 keras-applications-1.0.8 keras-preprocessing-1.1.2 markdown-3.2.2 numpy-1.19.0 oauthlib-3.1.0 opt-einsum-3.2.1 protobuf-3.12.2 pyasn1-0.4.8 pyasn1-modules-0.2.8 requests-oauthlib-1.3.0 rsa-4.6 scipy-1.4.1 tensorboard-2.1.1 tensorflow-cpu-2.1.0 tensorflow-estimator-2.1.0 termcolor-1.1.0 werkzeug-1.0.1 wrapt-1.12.1 zipp-3.1.0
Removing intermediate container 9cb79ea186fa
 ---> 9d8a322fb401
Step 5/13 : COPY requirements.txt .
 ---> d93346ba6eae
Step 6/13 : RUN pip install -r requirements.txt
 ---> Running in 64dab50e789c
Collecting ConfigSpace==0.4.10
  Downloading ConfigSpace-0.4.10.tar.gz (882 kB)
Collecting bayesian-optimization
  Downloading bayesian-optimization-1.2.0.tar.gz (14 kB)
Collecting boto3
  Downloading boto3-1.14.20-py2.py3-none-any.whl (128 kB)
Collecting dm_tree
  Downloading dm_tree-0.1.5-cp36-cp36m-manylinux1_x86_64.whl (294 kB)
Collecting dragonfly-opt
  Downloading dragonfly-opt-0.1.6.tar.gz (252 kB)
Collecting gym[atari]
  Downloading gym-0.17.2.tar.gz (1.6 MB)
Requirement already satisfied: h5py in /opt/conda/lib/python3.6/site-packages (from -r requirements.txt (line 7)) (2.10.0)
Collecting hpbandster
  Downloading hpbandster-0.7.4.tar.gz (51 kB)
Collecting hyperopt==0.1.2
  Downloading hyperopt-0.1.2-py3-none-any.whl (115 kB)
Collecting jupyter
  Downloading jupyter-1.0.0-py2.py3-none-any.whl (2.7 kB)
Collecting keras
  Downloading Keras-2.4.3-py2.py3-none-any.whl (36 kB)
Collecting lightgbm
  Downloading lightgbm-2.3.1-py2.py3-none-manylinux1_x86_64.whl (1.2 MB)
Collecting lz4
  Downloading lz4-3.1.0-cp36-cp36m-manylinux2010_x86_64.whl (1.8 MB)
Collecting matplotlib
  Downloading matplotlib-3.2.2-cp36-cp36m-manylinux1_x86_64.whl (12.4 MB)
Collecting mlflow
  Downloading mlflow-1.9.1-py3-none-any.whl (11.9 MB)
Collecting nevergrad
  Downloading nevergrad-0.4.1.post4-py3-none-any.whl (263 kB)
Collecting opencv-python-headless
  Downloading opencv_python_headless-4.3.0.36-cp36-cp36m-manylinux2014_x86_64.whl (36.4 MB)
Collecting pandas
  Downloading pandas-1.0.5-cp36-cp36m-manylinux1_x86_64.whl (10.1 MB)
Collecting pytest-remotedata>=0.3.1
  Downloading pytest_remotedata-0.3.2-py2.py3-none-any.whl (8.3 kB)
Collecting pytest-timeout
  Downloading pytest_timeout-1.4.1-py2.py3-none-any.whl (10 kB)
Collecting pytorch-lightning
  Downloading pytorch_lightning-0.8.5-py3-none-any.whl (313 kB)
Collecting scikit-learn==0.22.2
  Downloading scikit_learn-0.22.2-cp36-cp36m-manylinux1_x86_64.whl (7.1 MB)
Collecting scikit-optimize
  Downloading scikit_optimize-0.7.4-py2.py3-none-any.whl (80 kB)
Collecting sigopt
  Downloading sigopt-5.7.0-py2.py3-none-any.whl (20 kB)
Collecting smart_open
  Downloading smart_open-2.1.0.tar.gz (116 kB)
Collecting tabulate
  Downloading tabulate-0.8.7-py3-none-any.whl (24 kB)
Collecting tensorboardX
  Downloading tensorboardX-2.1-py2.py3-none-any.whl (308 kB)
Collecting tensorflow_probability
  Downloading tensorflow_probability-0.10.1-py2.py3-none-any.whl (3.5 MB)
Requirement already satisfied: torch in /opt/conda/lib/python3.6/site-packages (from -r requirements.txt (line 29)) (1.4.0+cpu)
Requirement already satisfied: torchvision in /opt/conda/lib/python3.6/site-packages (from -r requirements.txt (line 30)) (0.5.0+cpu)
Collecting xgboost
  Downloading xgboost-1.1.1-py3-none-manylinux2010_x86_64.whl (127.6 MB)
Collecting zoopt>=0.4.0
  Downloading zoopt-0.4.0-py2.py3-none-any.whl (57 kB)
Collecting timm
  Downloading timm-0.1.30-py3-none-any.whl (207 kB)
Collecting dataclasses
  Downloading dataclasses-0.7-py3-none-any.whl (18 kB)
ERROR: Could not find a version that satisfies the requirement tune-sklearn==0.0.5 (from -r requirements.txt (line 35)) (from versions: 0.0.0, 0.0.1, 0.0.2, 0.0.3, 0.0.4)
ERROR: No matching distribution found for tune-sklearn==0.0.5 (from -r requirements.txt (line 35))
The command '/bin/sh -c pip install -r requirements.txt' returned a non-zero code: 1
+ DOCKER_SHA=
+ [[ 3 -lt 3 ]]
+ echo 'The command has failed after 3 attempts.'
The command has failed after 3 attempts.
+ exit 1
Build step 'Execute shell' marked build as failure
Setting commit status on GitHub for https://github.com/ray-project/ray/commit/7eacf677a29a8a318959e53f14c2f936b98a7520
Test FAILed.
Refer to this link for build results (access rights to CI server needed): 
https://amplab.cs.berkeley.edu/jenkins//job/Ray-PRB/28386/
Test FAILed.
Finished: FAILURE