SuccessChanges

Summary

  1. [MINOR][TEST] Expand spark-submit test to allow python2/3 executable (commit: 233646c374b6dbcedc59f604f3b70060df20f093) (details)
  2. [SPARK-25079][PYTHON][BRANCH-2.3] update python3 executable to 3.6.x (commit: a85ab120e3d29a323e6d28aa307d4c20ee5f2c6c) (details)
Commit 233646c374b6dbcedc59f604f3b70060df20f093 by dhyun
[MINOR][TEST] Expand spark-submit test to allow python2/3 executable
## What changes were proposed in this pull request?
This backports a tiny part of another change:
https://github.com/apache/spark/commit/4bdfda92a1c570d7a1142ee30eb41e37661bc240#diff-3c792ce7265b69b448a984caf629c96bR161
... which just works around the possibility that the local python
interpreter is 'python3' or 'python2' when running the spark-submit
tests.
I'd like to backport to 2.3 too.
This otherwise prevents this test from passing on my mac, though I have
a custom install with brew. But may affect others.
## How was this patch tested?
Existing tests.
Closes #24407 from srowen/Python23check.
Authored-by: Sean Owen <sean.owen@databricks.com> Signed-off-by:
Dongjoon Hyun <dhyun@apple.com>
(cherry picked from commit 7f64963c9d951585f585f98667f09e9ddbe63731)
Signed-off-by: Dongjoon Hyun <dhyun@apple.com>
(commit: 233646c374b6dbcedc59f604f3b70060df20f093)
The file was modifiedlauncher/src/test/java/org/apache/spark/launcher/SparkSubmitCommandBuilderSuite.java (diff)
Commit a85ab120e3d29a323e6d28aa307d4c20ee5f2c6c by incomplete
[SPARK-25079][PYTHON][BRANCH-2.3] update python3 executable to 3.6.x
## What changes were proposed in this pull request?
have jenkins test against python3.6 (instead of 3.4).
## How was this patch tested?
extensive testing on both the centos and ubuntu jenkins workers revealed
that 2.3 probably doesn't like python 3.6... :(
NOTE: this is just for branch-2.3
PLEASE DO NOT MERGE
Author: shane knapp <incomplete@gmail.com>
Closes #24380 from shaneknapp/update-python-executable-2.3.
(commit: a85ab120e3d29a323e6d28aa307d4c20ee5f2c6c)
The file was modifiedpython/run-tests.py (diff)