SuccessChanges

Summary

  1. [SPARK-27638][SQL][FOLLOW-UP] Format config name to follow the other (details)
Commit 83d289eef492de8c7f3e5145f9bd75431608b500 by gurwls223
[SPARK-27638][SQL][FOLLOW-UP] Format config name to follow the other
boolean conf naming convention
### What changes were proposed in this pull request?
Change config name from `spark.sql.legacy.typeCoercion.datetimeToString`
to `spark.sql.legacy.typeCoercion.datetimeToString.enabled`.
### Why are the changes needed?
To follow the other boolean conf naming convention.
### Does this PR introduce any user-facing change?
No, it's newly added in Spark 3.0.
### How was this patch tested?
Pass Jenkins
Closes #27065 from Ngone51/SPARK-27638-FOLLOWUP.
Authored-by: yi.wu <yi.wu@databricks.com> Signed-off-by: HyukjinKwon
<gurwls223@apache.org>
The file was modifiedsql/catalyst/src/main/scala/org/apache/spark/sql/internal/SQLConf.scala (diff)
The file was modifieddocs/sql-migration-guide.md (diff)