SuccessConsole Output

Started by an SCM change
[EnvInject] - Loading node environment variables.
Building remotely on amp-jenkins-staging-worker-02 (ubuntu staging-02 staging) in workspace /home/jenkins/workspace/e-mission-server
[WS-CLEANUP] Deleting project workspace...
[WS-CLEANUP] Done
Cloning the remote Git repository
Cloning repository https://github.com/e-mission/e-mission-server
 > git init /home/jenkins/workspace/e-mission-server # timeout=10
Fetching upstream changes from https://github.com/e-mission/e-mission-server
 > git --version # timeout=10
 > git fetch --tags --progress https://github.com/e-mission/e-mission-server +refs/heads/*:refs/remotes/origin/*
 > git config remote.origin.url https://github.com/e-mission/e-mission-server # timeout=10
 > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git config remote.origin.url https://github.com/e-mission/e-mission-server # timeout=10
Fetching upstream changes from https://github.com/e-mission/e-mission-server
 > git fetch --tags --progress https://github.com/e-mission/e-mission-server +refs/heads/*:refs/remotes/origin/*
 > git rev-parse refs/remotes/origin/master^{commit} # timeout=10
 > git rev-parse refs/remotes/origin/origin/master^{commit} # timeout=10
Checking out Revision d27c0c22c3d0ba51047504cb83d0fc75ef0bd63a (refs/remotes/origin/master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f d27c0c22c3d0ba51047504cb83d0fc75ef0bd63a
 > git rev-list 133644b2ea78d61aab7c7e8523e86ee6e043c2df # timeout=10
[e-mission-server] $ /bin/bash /tmp/hudson7334485503604626779.sh
Deploying environment in /tmp/tmp.ulftnyeIR9
Make sure you are running this with conda >=4.2
Check with 'conda -V'
Upgrade with 'conda update conda' from the *root* environment
Using Anaconda API: https://api.anaconda.org
Fetching package metadata ...........
Solving package specifications: .
Collecting arrow==0.12.0
Collecting attrdict==2.0.0
Requirement already satisfied: backports.shutil-get-terminal-size==1.0.0 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages
Collecting cachetools==2.0.1
  Using cached cachetools-2.0.1-py2.py3-none-any.whl
Collecting certifi==2017.11.5
  Using cached certifi-2017.11.5-py2.py3-none-any.whl
Collecting cheroot==5.10.0
  Using cached cheroot-5.10.0-py2.py3-none-any.whl
Collecting enum34==1.1.6
  Using cached enum34-1.1.6-py3-none-any.whl
Requirement already satisfied: et-xmlfile==1.0.1 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages
Collecting future==0.16.0
Collecting geojson==2.3.0
  Using cached geojson-2.3.0-py2.py3-none-any.whl
Collecting google-auth==1.2.1
  Using cached google_auth-1.2.1-py2.py3-none-any.whl
Requirement already satisfied: ipython-genutils==0.2.0 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages
Collecting jaraco.classes==1.4.3
  Using cached jaraco.classes-1.4.3-py2.py3-none-any.whl
Requirement already satisfied: jupyter-client==5.0.1 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages
Requirement already satisfied: jupyter-console==5.1.0 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages
Requirement already satisfied: jupyter-core==4.3.0 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages
Collecting jwcrypto==0.4.2
  Using cached jwcrypto-0.4.2-py2.py3-none-any.whl
Collecting portend==2.2
  Using cached portend-2.2-py2.py3-none-any.whl
Requirement already satisfied: prompt-toolkit==1.0.14 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages
Collecting pyasn1==0.4.2
  Using cached pyasn1-0.4.2-py2.py3-none-any.whl
Collecting pyasn1-modules==0.2.1
  Using cached pyasn1_modules-0.2.1-py2.py3-none-any.whl
Collecting pyfcm==1.4.3
Collecting pygeocoder==1.2.5
Collecting pykml==0.1.3
Collecting pymongo==3.5.1
  Using cached pymongo-3.5.1-cp36-cp36m-manylinux1_x86_64.whl
Collecting python-crontab==2.2.7
Collecting requests-toolbelt==0.8.0
  Using cached requests_toolbelt-0.8.0-py2.py3-none-any.whl
Requirement already satisfied: rope-py3k==0.9.4.post1 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages
Collecting rsa==3.4.2
  Using cached rsa-3.4.2-py2.py3-none-any.whl
Requirement already satisfied: tables==3.3.0 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages
Collecting tempora==1.9
  Using cached tempora-1.9-py2.py3-none-any.whl
Collecting urllib3==1.22
  Using cached urllib3-1.22-py2.py3-none-any.whl
Collecting utm==0.4.2
Collecting xmltodict==0.11.0
  Using cached xmltodict-0.11.0-py2.py3-none-any.whl
Requirement already satisfied: python-dateutil in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from arrow==0.12.0)
Requirement already satisfied: six in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from attrdict==2.0.0)
Requirement already satisfied: traitlets in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from jupyter-client==5.0.1)
Requirement already satisfied: pyzmq>=13 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from jupyter-client==5.0.1)
Requirement already satisfied: ipython in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from jupyter-console==5.1.0)
Requirement already satisfied: ipykernel in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from jupyter-console==5.1.0)
Requirement already satisfied: pygments in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from jupyter-console==5.1.0)
Requirement already satisfied: cryptography>=1.5 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from jwcrypto==0.4.2)
Requirement already satisfied: wcwidth in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from prompt-toolkit==1.0.14)
Requirement already satisfied: requests in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from pyfcm==1.4.3)
Requirement already satisfied: lxml>=2.2.6 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from pykml==0.1.3)
Requirement already satisfied: numpy>=1.8.0 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from tables==3.3.0)
Requirement already satisfied: numexpr>=2.5.2 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from tables==3.3.0)
Requirement already satisfied: pytz in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from tempora==1.9)
Requirement already satisfied: decorator in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from traitlets->jupyter-client==5.0.1)
Requirement already satisfied: simplegeneric>0.8 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from ipython->jupyter-console==5.1.0)
Requirement already satisfied: pexpect; sys_platform != "win32" in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from ipython->jupyter-console==5.1.0)
Requirement already satisfied: pickleshare in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from ipython->jupyter-console==5.1.0)
Requirement already satisfied: setuptools>=18.5 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages/setuptools-27.2.0-py3.6.egg (from ipython->jupyter-console==5.1.0)
Requirement already satisfied: tornado>=4.0 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from ipykernel->jupyter-console==5.1.0)
Requirement already satisfied: idna>=2.1 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from cryptography>=1.5->jwcrypto==0.4.2)
Requirement already satisfied: asn1crypto>=0.21.0 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from cryptography>=1.5->jwcrypto==0.4.2)
Requirement already satisfied: packaging in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from cryptography>=1.5->jwcrypto==0.4.2)
Requirement already satisfied: cffi>=1.4.1 in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from cryptography>=1.5->jwcrypto==0.4.2)
Requirement already satisfied: pyparsing in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from packaging->cryptography>=1.5->jwcrypto==0.4.2)
Requirement already satisfied: pycparser in /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages (from cffi>=1.4.1->cryptography>=1.5->jwcrypto==0.4.2)
Installing collected packages: arrow, attrdict, cachetools, certifi, cheroot, enum34, future, geojson, pyasn1, pyasn1-modules, rsa, google-auth, jaraco.classes, jwcrypto, tempora, portend, requests-toolbelt, pyfcm, pygeocoder, pykml, pymongo, python-crontab, urllib3, utm, xmltodict
Successfully installed arrow-0.12.0 attrdict-2.0.0 cachetools-2.0.1 certifi-2017.11.5 cheroot-5.10.0 enum34-1.1.6 future-0.16.0 geojson-2.3.0 google-auth-1.2.1 jaraco.classes-1.4.3 jwcrypto-0.4.2 portend-2.2 pyasn1-0.4.2 pyasn1-modules-0.2.1 pyfcm-1.4.3 pygeocoder-1.2.5 pykml-0.1.3 pymongo-3.5.1 python-crontab-2.2.7 requests-toolbelt-0.8.0 rsa-3.4.2 tempora-1.9 urllib3-1.22 utm-0.4.2 xmltodict-0.11.0
Installing /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages/vega/static -> jupyter-vega
Making directory: /tmp/tmp.ulftnyeIR9/share/jupyter/nbextensions/jupyter-vega/
Copying: /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages/vega/static/index.js.map -> /tmp/tmp.ulftnyeIR9/share/jupyter/nbextensions/jupyter-vega/index.js.map
Copying: /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages/vega/static/vega.js -> /tmp/tmp.ulftnyeIR9/share/jupyter/nbextensions/jupyter-vega/vega.js
Copying: /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages/vega/static/index.js -> /tmp/tmp.ulftnyeIR9/share/jupyter/nbextensions/jupyter-vega/index.js
Copying: /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages/vega/static/vega.html -> /tmp/tmp.ulftnyeIR9/share/jupyter/nbextensions/jupyter-vega/vega.html
Copying: /tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages/vega/static/vega-lite.html -> /tmp/tmp.ulftnyeIR9/share/jupyter/nbextensions/jupyter-vega/vega-lite.html
- Validating: OK

    To initialize this nbextension in the browser every time the notebook (or other app) loads:
    
          jupyter nbextension enable vega --py --sys-prefix
    

#
# To activate this environment, use:
# > source activate /tmp/tmp.ulftnyeIR9
#
# To deactivate an active environment, use:
# > source deactivate
#

Collecting six
  Using cached six-1.11.0-py2.py3-none-any.whl
Installing collected packages: six
  Found existing installation: six 1.10.0
    DEPRECATION: Uninstalling a distutils installed project (six) has been deprecated and will be removed in a future version. This is due to the fact that uninstalling a distutils project will only partially uninstall the project.
    Uninstalling six-1.10.0:
      Successfully uninstalled six-1.10.0
Successfully installed six-1.11.0
/home/jenkins/workspace/e-mission-server/emission/core/get_database.py:251: DeprecationWarning: save is deprecated. Use insert_one or replace_one instead
  db.save(entry)
/tmp/tmp.ulftnyeIR9/lib/python3.6/site-packages/pandas/core/frame.py:891: UserWarning: DataFrame columns are not unique, some columns will be omitted.
  "columns will be omitted.", UserWarning)
Minimum number of clusters 10 is greater than the number of data points 8.
Must have at least 2 clusters
.Must have at least 2 clusters
Must have at least 2 clusters
...Must have at least 2 clusters
..No clusters to analyze
.Minimum number of clusters 9 is greater than the number of data points 8.
Minimum number of clusters 10 is greater than the number of data points 8.
.Must have at least 2 clusters
.Must have at least 2 clusters
.Must have at least 2 clusters
.Must have at least 2 clusters
.Must have at least 2 clusters
.Must have at least 2 clusters
.WARNING:root:No user defined overrides for 849d8c4e-580b-4c36-a12c-0b22d8b78f17, early return
WARNING:root:No user defined overrides for 849d8c4e-580b-4c36-a12c-0b22d8b78f17, early return
WARNING:root:No user defined overrides for 849d8c4e-580b-4c36-a12c-0b22d8b78f17, early return
.WARNING:root:No user defined overrides for 7b72b7d5-d9c1-4d88-a412-dfcdb211cec1, early return
WARNING:root:No user defined overrides for 7b72b7d5-d9c1-4d88-a412-dfcdb211cec1, early return
WARNING:root:No user defined overrides for 7b72b7d5-d9c1-4d88-a412-dfcdb211cec1, early return
.WARNING:root:No user defined overrides for a76021ea-2217-4c1f-9939-177643ab80e3, early return
WARNING:root:No user defined overrides for a76021ea-2217-4c1f-9939-177643ab80e3, early return
.WARNING:root:No user defined overrides for 983995aa-af7f-4a9b-a355-4e3af8c68953, early return
WARNING:root:No user defined overrides for 983995aa-af7f-4a9b-a355-4e3af8c68953, early return
........F.................................F....F..FF..........................................................................WARNING:root:Got error None while saving entry AttrDict({'_id': ObjectId('572d3621d282b8f30def7e85'), 'user_id': UUID('668c0df9-6ac2-4685-b80c-9b72d594f1cc'), 'data': {'transition': None, 'currState': 'STATE_ONGOING_TRIP'}, 'metadata': {'plugin': 'none', 'write_ts': 1518657654, 'time_zone': 'America/Los_Angeles', 'platform': 'ios', 'key': 'statemachine/transition', 'read_ts': 1518657652, 'type': 'message'}}) -> None
...........................E..F..storage not configured, falling back to sample, default configuration
Connecting to database URL localhost
debug not configured, falling back to sample, default configuration
google maps key not configured, falling back to nominatim
nominatim not configured either, place decoding must happen on the client
there are 8
there are 8
there are 8
there are 8
there are 8
there are 8
there are 8
there are 8
there are 8
collections = ['Stage_user_habitica_access', 'Stage_uuids', 'Stage_analysis_timeseries', 'Stage_Sections', 'Test_Trips', 'Stage_Profiles', 'Stage_pipeline_state', 'Stage_timeseries', 'Stage_usercache']
Dropping collection Stage_user_habitica_access
Dropping collection Stage_uuids
Dropping collection Stage_analysis_timeseries
Dropping collection Stage_Sections
Dropping collection Test_Trips
Dropping collection Stage_Profiles
Dropping collection Stage_pipeline_state
Dropping collection Stage_timeseries
Dropping collection Stage_usercache
collections = ['Stage_uuids', 'Stage_Modes', 'Stage_Sections', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Modes
Dropping collection Stage_Sections
Dropping collection Stage_Profiles
collections = ['Stage_uuids', 'Stage_Modes', 'Stage_Sections', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Modes
Dropping collection Stage_Sections
Dropping collection Stage_Profiles
collections = ['Stage_uuids', 'Stage_Modes', 'Stage_Sections', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Modes
Dropping collection Stage_Sections
Dropping collection Stage_Profiles
collections = ['Stage_uuids', 'Stage_Modes', 'Stage_Sections', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Modes
Dropping collection Stage_Sections
Dropping collection Stage_Profiles
collections = ['Stage_uuids', 'Stage_Modes', 'Stage_Sections', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Modes
Dropping collection Stage_Sections
Dropping collection Stage_Profiles
collections = ['Stage_uuids', 'Stage_Modes', 'Stage_Sections', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Modes
Dropping collection Stage_Sections
Dropping collection Stage_Profiles
collections = ['Stage_uuids', 'Stage_Modes', 'Stage_Sections', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Modes
Dropping collection Stage_Sections
Dropping collection Stage_Profiles
Number of sections = 10
Feature Matrix shape = (10, 22)
collections = ['Stage_uuids', 'Stage_Modes', 'Stage_Sections', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Modes
Dropping collection Stage_Sections
Dropping collection Stage_Profiles
collections = ['Stage_uuids', 'Stage_Modes', 'Stage_Sections', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Modes
Dropping collection Stage_Sections
Dropping collection Stage_Profiles
collections = ['Stage_uuids', 'Stage_Modes', 'Stage_Sections', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Modes
Dropping collection Stage_Sections
Dropping collection Stage_Profiles
collections = ['Stage_uuids', 'Stage_Modes', 'Stage_Sections', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Modes
Dropping collection Stage_Sections
Dropping collection Stage_Profiles
collections = ['Stage_uuids', 'Stage_Modes', 'Stage_Sections', 'Stage_analysis_timeseries', 'Stage_Profiles', 'Stage_pipeline_state', 'Stage_timeseries', 'Stage_usercache']
Dropping collection Stage_uuids
Dropping collection Stage_Modes
Dropping collection Stage_Sections
Dropping collection Stage_analysis_timeseries
Dropping collection Stage_Profiles
Dropping collection Stage_pipeline_state
Dropping collection Stage_timeseries
Dropping collection Stage_usercache
{'result_url': 'https://e-mission.eecs.berkeley.edu/test/test/test'}
collections = ['Stage_Modes', 'Stage_clients']
Dropping collection Stage_Modes
Dropping collection Stage_clients
collections = ['Stage_Modes']
Dropping collection Stage_Modes
collections = ['Stage_Modes', 'Stage_clients']
Dropping collection Stage_Modes
Dropping collection Stage_clients
collections = ['Stage_uuids', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Profiles
Returning total = 126, len = 3, avg = 42
collections = ['Stage_uuids', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Profiles
Returning total = 126, len = 3, avg = 42
collections = ['Stage_uuids', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Profiles
collections = ['Stage_uuids', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Profiles
collections = []
collections = []
collections = ['Stage_uuids', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Profiles
collections = ['Stage_uuids', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Profiles
collections = ['Stage_uuids', 'Stage_Profiles']
Dropping collection Stage_uuids
Dropping collection Stage_Profiles
collections = ['Stage_usercache']
Dropping collection Stage_usercache
collections = []
collections = ['Stage_usercache']
Dropping collection Stage_usercache
collections = []
collections = ['Stage_usercache']
Dropping collection Stage_usercache
collections = []
collections = ['Stage_usercache']
Dropping collection Stage_usercache
collections = []
collections = ['Stage_usercache']
Dropping collection Stage_usercache
collections = []
collections = ['Stage_usercache']
Dropping collection Stage_usercache
collections = []
collections = ['Stage_usercache']
Dropping collection Stage_usercache
collections = []
collections = ['Stage_usercache']
Dropping collection Stage_usercache
collections = []
collections = ['Stage_usercache']
Dropping collection Stage_usercache
collections = []
collections = ['Stage_pipeline_state', 'Stage_timeseries', 'Stage_usercache']
Dropping collection Stage_pipeline_state
Dropping collection Stage_timeseries
Dropping collection Stage_usercache
collections = ['Stage_pipeline_state', 'Stage_timeseries', 'Stage_usercache']
Dropping collection Stage_pipeline_state
Dropping collection Stage_timeseries
Dropping collection Stage_usercache
collections = ['Stage_timeseries_error', 'Stage_pipeline_state', 'Stage_timeseries', 'Stage_usercache']
Dropping collection Stage_timeseries_error
Dropping collection Stage_pipeline_state
Dropping collection Stage_timeseries
Dropping collection Stage_usercache
collections = ['Stage_pipeline_state', 'Stage_timeseries', 'Stage_usercache']
Dropping collection Stage_pipeline_state
Dropping collection Stage_timeseries
Dropping collection Stage_usercache
collections = ['Stage_usercache']
Dropping collection Stage_usercache
collections = ['Stage_usercache']
Dropping collection Stage_usercache
collections = ['Stage_usercache']
Dropping collection Stage_usercache
collections = ['Stage_usercache']
Dropping collection Stage_usercache
Test setup called
Test setup called
Test setup called
Test setup called
[[-122.0846749, 37.393415], [-122.08367716219298, 37.3948067779213], [-122.08310408579901, 37.3956920043855], [-122.08303055467863, 37.39583125008914], [-122.08297393900254, 37.39593205132939], [-122.08287328402464, 37.39603598782679], [-122.08217139950614, 37.39586915745068], [-122.08121687635078, 37.39662502176472], [-122.08083540229008, 37.397986347667576], [-122.0807141489917, 37.39929928253347], [-122.0805674333962, 37.39999204611759], [-122.08069534712718, 37.39996179457042], [-122.08142813111742, 37.39994239741808], [-122.08307863820072, 37.400177859918735], [-122.08468667951159, 37.40064209653733], [-122.08484181367525, 37.401718181087354], [-122.08479822727575, 37.40260859261417], [-122.08471328637039, 37.403095985737], [-122.0847081, 37.4033491], [-122.0835641, 37.4034802], [-122.08324947759913, 37.403249485086526], [-122.08293485519823, 37.403018770173055], [-122.08262023279735, 37.402788055259585], [-122.08230561039646, 37.402557340346114], [-122.08146304068424, 37.40240305189178], [-122.0798705375145, 37.40192739503022], [-122.0791330715329, 37.401570416313966], [-122.07900239094822, 37.40154684580483], [-122.07839491401299, 37.40110036136816], [-122.07793701515128, 37.39922447059321], [-122.07727089547438, 37.39817899676297], [-122.0763436450106, 37.39786335105958], [-122.07721299122628, 37.39661146003307], [-122.0778060271274, 37.39579266489395], [-122.0778487389895, 37.39573904255864], [-122.07784370441615, 37.39575069197053], [-122.07781181592573, 37.395726926020124], [-122.0778188, 37.3957356], [-122.078664, 37.4015876], [-122.0796973, 37.4021489], [-122.0804791, 37.3959724], [-122.08297204509547, 37.3959456445923], [-122.08297270839385, 37.39598051606153], [-122.0836783940137, 37.39483405888615], [-122.08441549613816, 37.39375391129058], [-122.08488551380876, 37.393052509223544], [-122.08547548499102, 37.3920663815419], [-122.08607344217683, 37.39113822877281], [-122.08622899782469, 37.39095885504853], [-122.08622857893772, 37.39099206421023], [-122.08626055360769, 37.39097112682174], [-122.0862609, 37.3909709]].......................................Must have at least 2 clusters
........E....
======================================================================
ERROR: testFcmMapping (netTests.TestPush.TestPush)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jenkins/workspace/e-mission-server/emission/tests/netTests/TestPush.py", line 105, in testFcmMapping
    (mapped_list, unmapped_list) = fcm_instance.map_existing_fcm_tokens(self.test_token_list)
  File "/home/jenkins/workspace/e-mission-server/emission/net/ext_service/push/notify_interface_impl/firebase.py", line 38, in map_existing_fcm_tokens
    "android": token_map["android"]}
TypeError: list indices must be integers or slices, not str

======================================================================
ERROR: testUserInputRealData (storageTests.TestTripQueries.TestTripQueries)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jenkins/workspace/e-mission-server/emission/tests/storageTests/TestTripQueries.py", line 150, in testUserInputRealData
    etc.setupRealExample(self, dataFile)
NameError: name 'etc' is not defined

======================================================================
FAIL: testFilterAccuracy (analysisTests.intakeTests.TestFilterAccuracy.TestFilterAccuracy)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jenkins/workspace/e-mission-server/emission/tests/analysisTests/intakeTests/TestFilterAccuracy.py", line 113, in testFilterAccuracy
    self.assertEqual(len(filtered_points_df), 124)
AssertionError: 0 != 124

======================================================================
FAIL: testIOSSegmentationWrapperWithAutoTrip (analysisTests.intakeTests.TestSectionSegmentation.TestSectionSegmentation)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jenkins/workspace/e-mission-server/emission/tests/analysisTests/intakeTests/TestSectionSegmentation.py", line 216, in testIOSSegmentationWrapperWithAutoTrip
    self.assertEqual(len(created_trips), 2)
AssertionError: 0 != 2

======================================================================
FAIL: testSegmentationPointsDwellSegmentationDistFilter (analysisTests.intakeTests.TestTripSegmentation.TestTripSegmentation)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jenkins/workspace/e-mission-server/emission/tests/analysisTests/intakeTests/TestTripSegmentation.py", line 90, in testSegmentationPointsDwellSegmentationDistFilter
    self.assertEqual(len(segmentation_points), 2)
AssertionError: 0 != 2

======================================================================
FAIL: testSegmentationWrapperCombined (analysisTests.intakeTests.TestTripSegmentation.TestTripSegmentation)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jenkins/workspace/e-mission-server/emission/tests/analysisTests/intakeTests/TestTripSegmentation.py", line 209, in testSegmentationWrapperCombined
    self.assertEqual(len(created_places_entries), 11)
AssertionError: 9 != 11

======================================================================
FAIL: testSegmentationWrapperIOS (analysisTests.intakeTests.TestTripSegmentation.TestTripSegmentation)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jenkins/workspace/e-mission-server/emission/tests/analysisTests/intakeTests/TestTripSegmentation.py", line 159, in testSegmentationWrapperIOS
    self.assertEqual(len(created_places_entries), 2)
AssertionError: 0 != 2

======================================================================
FAIL: testMappingQueries (netTests.TestPush.TestPush)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jenkins/workspace/e-mission-server/emission/tests/netTests/TestPush.py", line 87, in testMappingQueries
    self.assertEqual(uuid_token_list, ["ios_device_token", "android_device_token"])
AssertionError: {'ios': ['ios_device_token'], 'android': ['android_device_token']} != ['ios_device_token', 'android_device_token']

----------------------------------------------------------------------
Ran 228 tests in 819.505s

FAILED (failures=6, errors=2)

Found match for {'_id': ObjectId('5a84e149f6ec1c0ec405f082'), 'track_location': {'type': 'Point', 'coordinates': [-122.5, 37.5]}}
Found match for {'_id': ObjectId('5a84e149f6ec1c0ec405f085'), 'track_location': {'type': 'Point', 'coordinates': [-122.5, 37.5]}}
Found match for {'_id': ObjectId('5a84e149f6ec1c0ec405f086'), 'track_location': {'type': 'Point', 'coordinates': [-122.259475, 37.87237]}}
Found match for {'_id': ObjectId('5a84e149f6ec1c0ec405f087'), 'track_location': {'type': 'Point', 'coordinates': [-122.259169, 37.873873]}}
Found match for {'_id': ObjectId('5a84e149f6ec1c0ec405f088'), 'track_location': {'type': 'Point', 'coordinates': [-122.25874, 37.875711]}}
Found match for {'_id': ObjectId('5a84e149f6ec1c0ec405f089'), 'track_location': {'type': 'Point', 'coordinates': [-122.254577, 37.870352]}}
Found match for {'_id': ObjectId('5a84e149f6ec1c0ec405f085'), 'track_location': {'type': 'Point', 'coordinates': [-122.5, 37.5]}}
Found match for {'_id': ObjectId('5a84e149f6ec1c0ec405f086'), 'track_location': {'type': 'Point', 'coordinates': [-122.259475, 37.87237]}}
Found match for {'_id': ObjectId('5a84e149f6ec1c0ec405f087'), 'track_location': {'type': 'Point', 'coordinates': [-122.259169, 37.873873]}}
Found match for {'_id': ObjectId('5a84e149f6ec1c0ec405f088'), 'track_location': {'type': 'Point', 'coordinates': [-122.25874, 37.875711]}}
Found match for {'_id': ObjectId('5a84e149f6ec1c0ec405f089'), 'track_location': {'type': 'Point', 'coordinates': [-122.254577, 37.870352]}}
Removing environment from /tmp/tmp.ulftnyeIR9

Package plan for package removal in environment /tmp/tmp.ulftnyeIR9:

The following packages will be REMOVED:

    _license:           1.1-py36_1                    
    alabaster:          0.7.10-py36_0                 
    altair:             1.2.1-py_0         conda-forge
    anaconda:           4.4.0-np112py36_0             
    anaconda-client:    1.6.3-py36_0       conda-forge
    anaconda-navigator: 1.6.2-py36_0                  
    anaconda-project:   0.6.0-py36_0                  
    asn1crypto:         0.22.0-py36_0      conda-forge
    astroid:            1.4.9-py36_0                  
    astropy:            1.3.2-np112py36_0  conda-forge
    babel:              2.4.0-py36_0       conda-forge
    backports:          1.0-py36_0         conda-forge
    beautifulsoup4:     4.6.0-py36_0       conda-forge
    bitarray:           0.8.1-py36_0       conda-forge
    blaze:              0.10.1-py36_0                 
    bleach:             1.5.0-py36_0       conda-forge
    bokeh:              0.12.5-py36_1                 
    boto:               2.46.1-py36_0                 
    boto3:              1.5.26-py_0        conda-forge
    botocore:           1.8.40-py_0        conda-forge
    bottleneck:         1.2.1-np112py36_0  conda-forge
    branca:             0.2.0-py_1         conda-forge
    ca-certificates:    2018.1.18-0        conda-forge
    cairo:              1.14.8-0                      
    cffi:               1.10.0-py36_0      conda-forge
    chardet:            3.0.3-py36_0                  
    click:              6.7-py36_0         conda-forge
    cloudpickle:        0.2.2-py36_0                  
    clyent:             1.2.2-py36_0       conda-forge
    colorama:           0.3.9-py36_0       conda-forge
    contextlib2:        0.5.5-py36_0       conda-forge
    cryptography:       1.8.1-py36_0                  
    curl:               7.52.1-0           conda-forge
    cycler:             0.10.0-py36_0      conda-forge
    cython:             0.25.2-py36_0      conda-forge
    cytoolz:            0.8.2-py36_0       conda-forge
    dask:               0.14.3-py36_1                 
    datashape:          0.5.4-py36_0       conda-forge
    dbus:               1.10.10-0          conda-forge
    decorator:          4.0.11-py36_0      conda-forge
    distributed:        1.16.3-py36_0      conda-forge
    docutils:           0.13.1-py36_0      conda-forge
    entrypoints:        0.2.2-py36_1       conda-forge
    et_xmlfile:         1.0.1-py36_0       conda-forge
    expat:              2.1.0-0            conda-forge
    fastcache:          1.0.2-py36_1                  
    flask:              0.12.2-py36_0      conda-forge
    flask-cors:         3.0.2-py36_0                  
    folium:             0.5.0-py_0         conda-forge
    fontconfig:         2.12.1-3                      
    freetype:           2.5.5-2                       
    get_terminal_size:  1.0.0-py36_0                  
    gevent:             1.2.1-py36_0                  
    glib:               2.50.2-1                      
    gmp:                6.1.2-0            conda-forge
    greenlet:           0.4.12-py36_0      conda-forge
    gst-plugins-base:   1.8.0-0            conda-forge
    gstreamer:          1.8.0-0            conda-forge
    h5py:               2.7.0-np112py36_0  conda-forge
    harfbuzz:           0.9.39-2                      
    hdf5:               1.8.17-1                      
    heapdict:           1.0.0-py36_1                  
    html5lib:           0.999-py36_0       conda-forge
    icu:                54.1-0                        
    idna:               2.5-py36_0         conda-forge
    imageio:            2.2.0-py36_0       conda-forge
    imagesize:          0.7.1-py36_0       conda-forge
    ipykernel:          4.6.1-py36_0       conda-forge
    ipython:            5.3.0-py36_0       conda-forge
    ipython_genutils:   0.2.0-py36_0       conda-forge
    ipywidgets:         6.0.0-py36_0       conda-forge
    isort:              4.2.5-py36_0       conda-forge
    itsdangerous:       0.24-py36_0                   
    jbig:               2.1-0              conda-forge
    jdcal:              1.3-py36_0         conda-forge
    jedi:               0.10.2-py36_2                 
    jinja2:             2.9.6-py36_0       conda-forge
    jmespath:           0.9.3-py36_0       conda-forge
    jpeg:               9b-0               conda-forge
    jsonschema:         2.6.0-py36_0       conda-forge
    jupyter:            1.0.0-py36_3                  
    jupyter_client:     5.0.1-py36_0       conda-forge
    jupyter_console:    5.1.0-py36_0       conda-forge
    jupyter_core:       4.3.0-py36_0       conda-forge
    lazy-object-proxy:  1.2.2-py36_0       conda-forge
    libffi:             3.2.1-1            conda-forge
    libgcc:             4.8.5-2                       
    libgfortran:        3.0.0-1                       
    libiconv:           1.14-0             conda-forge
    libpng:             1.6.27-0                      
    libsodium:          1.0.10-0           conda-forge
    libtiff:            4.0.6-3                       
    libtool:            2.4.2-0                       
    libxcb:             1.12-1             conda-forge
    libxml2:            2.9.4-0                       
    libxslt:            1.1.29-0           conda-forge
    llvmlite:           0.18.0-py36_0                 
    locket:             0.2.0-py36_1       conda-forge
    lxml:               3.7.3-py36_0       conda-forge
    markupsafe:         0.23-py36_2                   
    matplotlib:         2.0.2-np112py36_0             
    mccabe:             0.6.1-py36_0       conda-forge
    mistune:            0.7.4-py36_0       conda-forge
    mkl:                2017.0.1-0                    
    mkl-service:        1.1.2-py36_3                  
    mpmath:             0.19-py36_1                   
    msgpack-python:     0.4.8-py36_0       conda-forge
    multipledispatch:   0.4.9-py36_0       conda-forge
    navigator-updater:  0.1.0-py36_0                  
    nbconvert:          5.1.1-py36_0       conda-forge
    nbformat:           4.3.0-py36_0       conda-forge
    ncurses:            5.9-10             conda-forge
    networkx:           1.11-py36_0        conda-forge
    nltk:               3.2.3-py36_0                  
    nose:               1.3.7-py36_1                  
    notebook:           5.0.0-py36_0       conda-forge
    numba:              0.33.0-np112py36_0            
    numexpr:            2.6.2-np112py36_0  conda-forge
    numpy:              1.12.1-py36_0                 
    numpydoc:           0.6.0-py36_0       conda-forge
    odo:                0.5.0-py36_1                  
    olefile:            0.44-py36_0        conda-forge
    openpyxl:           2.4.7-py36_0                  
    openssl:            1.0.2l-0           conda-forge
    packaging:          16.8-py36_0        conda-forge
    pandas:             0.20.1-np112py36_0 conda-forge
    pandoc:             2.0.0.1-0          conda-forge
    pandocfilters:      1.4.1-py36_0       conda-forge
    pango:              1.40.3-1                      
    partd:              0.3.8-py36_0       conda-forge
    path.py:            10.3.1-py36_0      conda-forge
    pathlib2:           2.2.1-py36_0       conda-forge
    patsy:              0.4.1-py36_0       conda-forge
    pcre:               8.39-1                        
    pep8:               1.7.0-py36_0       conda-forge
    pexpect:            4.2.1-py36_0       conda-forge
    pickleshare:        0.7.4-py36_0       conda-forge
    pillow:             4.1.1-py36_0                  
    pip:                9.0.1-py36_1       conda-forge
    pixman:             0.34.0-0           conda-forge
    ply:                3.10-py36_0        conda-forge
    prompt_toolkit:     1.0.14-py36_0      conda-forge
    psutil:             5.2.2-py36_0       conda-forge
    ptyprocess:         0.5.1-py36_0       conda-forge
    py:                 1.4.33-py36_0      conda-forge
    pycosat:            0.6.2-py36_0       conda-forge
    pycparser:          2.17-py36_0        conda-fWARNING conda.core.link:run_script(516): pre-unlink script failed for package conda-forge::vega-0.4.4-py36_1
consider notifying the package maintainer
WARNING conda.core.link:run_script(516): pre-unlink script failed for package conda-forge::widgetsnbextension-2.0.0-py36_0
consider notifying the package maintainer
orge
    pycrypto:           2.6.1-py36_6                  
    pycurl:             7.43.0-py36_2                 
    pyflakes:           1.5.0-py36_0       conda-forge
    pygments:           2.2.0-py36_0       conda-forge
    pylint:             1.6.4-py36_1       conda-forge
    pyodbc:             4.0.16-py36_0                 
    pyopenssl:          17.0.0-py36_0                 
    pyparsing:          2.1.4-py36_0                  
    pyqt:               5.6.0-py36_2       conda-forge
    pytables:           3.3.0-np112py36_0  conda-forge
    pytest:             3.0.7-py36_0       conda-forge
    python:             3.6.1-2            conda-forge
    python-dateutil:    2.6.0-py36_0       conda-forge
    pytz:               2017.2-py36_0      conda-forge
    pywavelets:         0.5.2-np112py36_0  conda-forge
    pyyaml:             3.12-py36_0        conda-forge
    pyzmq:              16.0.2-py36_0                 
    qt:                 5.6.2-4                       
    qtawesome:          0.4.4-py36_0       conda-forge
    qtconsole:          4.3.0-py36_0       conda-forge
    qtpy:               1.2.1-py36_0       conda-forge
    readline:           6.2-2                         
    requests:           2.14.2-py36_0                 
    rope:               0.9.4-py36_1                  
    ruamel_yaml:        0.11.14-py36_1                
    s3fs:               0.1.3-py_0         conda-forge
    s3transfer:         0.1.12-py36_0      conda-forge
    scikit-image:       0.13.0-np112py36_0 conda-forge
    scikit-learn:       0.18.1-np112py36_1            
    scipy:              0.19.0-np112py36_0            
    seaborn:            0.7.1-py36_0       conda-forge
    setuptools:         27.2.0-py36_0                 
    simplegeneric:      0.8.1-py36_1                  
    singledispatch:     3.4.0.3-py36_0     conda-forge
    sip:                4.18-py36_0                   
    six:                1.10.0-py36_0                 
    snowballstemmer:    1.2.1-py36_0       conda-forge
    sortedcollections:  0.5.3-py36_0       conda-forge
    sortedcontainers:   1.5.7-py36_0       conda-forge
    sphinx:             1.5.6-py36_0       conda-forge
    spyder:             3.1.4-py36_0       conda-forge
    sqlalchemy:         1.1.9-py36_0                  
    sqlite:             3.13.0-0           conda-forge
    statsmodels:        0.8.0-np112py36_0             
    sympy:              1.0-py36_0         conda-forge
    tblib:              1.3.2-py36_0       conda-forge
    terminado:          0.6-py36_0         conda-forge
    testpath:           0.3-py36_0         conda-forge
    tk:                 8.5.18-0                      
    toolz:              0.8.2-py36_0       conda-forge
    tornado:            4.5.1-py36_0       conda-forge
    traitlets:          4.3.2-py36_0       conda-forge
    unicodecsv:         0.14.1-py36_0      conda-forge
    unixodbc:           2.3.4-0            conda-forge
    vega:               0.4.4-py36_1       conda-forge
    vincent:            0.4.4-py36_0       conda-forge
    wcwidth:            0.1.7-py36_0       conda-forge
    webencodings:       0.5-py36_0         conda-forge
    werkzeug:           0.12.2-py36_0      conda-forge
    wheel:              0.29.0-py36_0      conda-forge
    widgetsnbextension: 2.0.0-py36_0       conda-forge
    wrapt:              1.10.10-py36_0                
    xlrd:               1.0.0-py36_0       conda-forge
    xlsxwriter:         0.9.6-py36_0       conda-forge
    xlwt:               1.2.0-py36_0       conda-forge
    xorg-libxau:        1.0.8-3            conda-forge
    xorg-libxdmcp:      1.1.2-3            conda-forge
    xz:                 5.2.2-1                       
    yaml:               0.1.6-0            conda-forge
    zeromq:             4.1.5-0            conda-forge
    zict:               0.1.2-py36_0       conda-forge
    zlib:               1.2.8-3            conda-forge

/tmp/tmp.ulftnyeIR9/bin/.vega-pre-unlink.sh: line 1: /tmp/tmp.ulftnyeIR9/bin/jupyter-nbextension: No such file or directory

rm: cannot remove 'conf/net/int_service/giles_conf.json': No such file or directory
Finished: SUCCESS